Install folder Not Found

  Posted

Hello,

I have encountered the following problem

http://192.2.13.2/install/

Not Found

The requested URL /usr/home/server/www/htdocs/ was not found on this server. Apache/1.3.42 Server at server Port 80

I do not see installation folder. This is an htaccess redirect?

-foo

Replies

 Mokuji developer Posted

The /install/ path should indeed redirect based on the rewrite rules. Make sure the .htaccess file is present in the root folder and check if the mod_rewrite module is loaded.

How to find if Apache's mod_rewrite module is enabled, and if not -> enable it

Case 1:

If PHP is run as an Apache module it's easy to find the loaded module using phpinfo().

  1. Create a file named phpinfo.php, containing <?php phpinfo(); ?>
  2. Open the file using your browser.
  3. Search for mod_rewrite.

If mod_rewrite is installed, you should find it in the "Apache loaded modules". If not, you can enable it like this: Linux / Windows.

Case 2:

If PHP is run as CGI module then there is no such info in phpinfo. In this case you need to actually test it if you want to know if mod_rewrite module is enabled or not.

  1. Create an .htaccess in some subfolder and make sure it contains:

RewriteEngine on RewriteRule ^(.*)$ https://www.example.com/$1 [R=301,L]

Point your browser to the folder. If you get a Server Error, it isn't installed. If you the browser did redirect to https://www.example.com it is installed.

If mod_rewrite is enabled, but you still get a 404, please let us know the version of Mokuji as well as your server coniguration.

  Posted

Hello Bart,

mod_rewrite is loaded and sample redirect works.

I think Mokuji htaccess url keys problem. Especially trouble Apache/1.3.42.

-foo

 Mokuji developer Posted

I see you're using Apache 1.3, but this version is not supported. We require Apache 2.0 for using Mokuji.

Apache 2.0 was released in 2002. The majority of server distributions upgraded to version 2.x around 2007. Apache 1.3 reached "End of life" status with version 1.3.42 in 2010. Therefore Apache 1.3 won't officially be supported by Mokuji.

FreeBSD 6.4 provides an official update to Apache 2.2.9 (called the httpd package). We recommend that you send a friendly suggestion to your hosting provider to upgrade their software, just to remind them that their software hasn't seen any new features in 11 years.

If you can't upgrade Apache because your host doesn't allow that, check if your PHP installation runs on fastcgi or mod_php. If you run fastcgi, delete the default .htaccess file from your root directory and rename .htaccess-cgi to .htaccess. It could be that Mokuji also runs on the deprecated Apache-version 1.3, but we didn't test it.

I hope this solves your problem; let us know if you have any other questions.

  Posted

Hello Bart,

All my sites are currently using shared hosting and HTTP service is provided by the Apache 1.3 Web Server.

According to Netcraft Database, 473.000 people using Apache 1.3 and is the final stable release of the Apache 1.3 family.

I would suggest either Apache 1.3.x (which used shared) or Apache 2.x.x.

Mokuji currently only supports for apache2. It's a sad support for all of us.

Thank you for your reply.

-foo

 Mokuji developer Posted

Dear foo,

As seen on W3Tech's survey currently amongst the ~10 million top sites 95.5% of Apache installations are Version 2. And as stated, Apache 1.3 has reached "End of life" status. Particularly the later point means we won't support Apache 1.3.x.

That being said, you can attempt to modify the .htaccess file yourself. Some suggestions:

  • Shorthand character classes are not supported in 1.3. Try replacing \w instances with 0-9A-Za-z and \d with 0-9.
  • Some setups, such as CGI instances don't pass the E flag environment variables. Use the .htacces-cgi file for that.
  Posted

Thank you for the information.

I'm having trouble locating the .htaccess file.

Shorthand character classes are not supported in 1.3. Try replacing \w instances with 0-9A-Za-z and \d with 0-9. Sample .htaccess is available for Apache 1.3? You share with me? Thus, I will have the opportunity to experiment.

Thank you.

 Mokuji developer Posted

Depending on your settings your .htaccess file may be hidden by your FTP server or your local file explorer. Because UNIX based systems consider files and folders starting with a . to be hidden files. The .htaccess file should be located in the root of your apache docroot (based on your first post that seems to be /usr/home/server/www/htdocs/.htaccess) and should look like this when you've uploaded the current Mokuji version.

We don't have an Apache 1.3 .htaccess sample file for Mokuji as we are only developing for Apache 2.x. I suggest you use the .htaccess-cgi file as a sample to experiment with. Because this includes an alternative to the E-flag.